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1. Introduction  
3D-Explorer is designed to visualize spatial models of biological macromolecules 

and their complexes (below referred to as models). The 3D-Explorer application is 
compatible with PDB files [1].  

The macromolecule can be presented as wire, stick, ball and stick, and CPK models.  
You can drag a macromolecule model with your mouse, rotate it, and change the 

size of models. 
You can also change the detail level and color of models and their elements. 
In 3D-Explorer, you can work with several types of molecular elements and show the 

structural features of a molecule as a matrix diagram. 

1.1. Installation 
1.1.1. Installing to Web-server 

1. To switch to the folder with distributive 
2. To compile the applet by the following sequence of commands: 

make clean 
make build 
make install 

3. To copy jar-file into required directory of the web-server 
4. To install «GetFile» program into cgi-bin folder of the Web-server 

1.1.2. Installing to local computer 
To install 3D-Explorer to local computer the following procedures are required: 

1. To install JRE 
2. To install Java3d RE 
3. To copy jar-file into required user’s directory 

1.2. Starting Softberry 3D Explorer (Java version) 
Softberry 3D Explorer Java version can be stared by the following means: 
1. Starting applet from the server with use of a certain HTML-code, inserted into 

html-page. 
2. Starting application: 

2.1 Starting application for work with Web-server. 
2.2 Starting application for local work. 

1.2.1. Starting the applet: 
The following html-code should be inserted into html-page: 
<APPLET ARCHIVE="proteins.jar" CODE="softberry.project.proteins.Base" 
CODEBASE="/proteins/" WIDTH=10 HEIGHT=10> 
<PARAM name="cgi" value="/cgi-bin/getfile"> 
<PARAM name="data_file" value="/var/www/tmp/java.KHgpna"> 
<PARAM name="help" value="/proteins/help/prot_hlp.html"> 
</APPLET> 

Where: 
ARCHIVE – name of the archive file with executable code of the applet. 
CODE – basic class of the applet. 
CODEBASE – catalog at the web-server with the archive of applet’s executable 

code. 
WIDTH – width of the applet on the internet-browser screen in pixels (it is not 

recommended to set it lesser than 10). 
HEIGHT – height of the applet on the internet-browser screen in pixels (it is not 

recommended to set it lesser than 10). 
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PARAM – a certain parameter of the applet with following attributes: 
name – name of a parameter. 
value – value of a parameter. 

Several parameters are allowed. There are essential for starting 3D-Explorer 
parameters: 
1. name=“cgi”. A value for this parameter is the relative URL for cgi-bin file (data and 

query server). On incorrect definition of this parameter, the applet will not work. 
2. name=“data_file”. A value for this parameter is the relative URL for file with data in 

special format (see chapter 1.3). On incorrect definition of this parameter, the 
applet will not work. 

3. name=“help”. A value for this parameter is the relative URL for documentation file. 
On incorrect definition of this parameter, the applet will not work. 

1.2.2. Starting the application 
The common way for the application startup has the following appearance: 
java –mx500 –cp “PATH_TO_JAR”proteins.jar softberry.project.proteins.Base 
[web options] 

1.2.2.1. Starting the application for working with Web-server 
Command for startup: 
java –mx500 –cp “PATH_TO_JAR”proteins.jar softberry.project.proteins.Base [–c 
getatoms_cgi] [-get getfile_cgi]  [-cce ce_cgi] [-sQH sQH_cgi] [-host host][-
port port] 

Value for parameter «–host» is defined by the Web-server, used for access to 
server application. This parameter is essential for working with Web-server. 

Value for parameter «–port» is defined by the port, used for working with Web-
server. This parameter is not essential. Default value is 80. 

Value for parameter «–c» is defined by the relative URL for server application 
GetAtoms. The pathway to server application is defined in relation to Web-server. On 
incorrect definition of this parameter, the work with GetAtoms will be unavailable. 

Value for parameter «–get» is defined by the relative URL for server application 
GetFile. The pathway to server application is defined in relation to Web-server. This is 
an essential parameter for work with Web-server. 

1.2.2.1. Starting the application for local work 
Command for startup: 
java –mx500 –cp “PATH_TO_JAR”proteins.jar softberry.project.proteins.Base 

1.2.3. Data formats for work with Web-server 

1.2.3.1. Data format for downloading from server 
STRUCTURE__ 
The list of structures can be empty. A single string corresponds to a single structure. A 
string has the following appearance: 
file structureId 
where: 
file – name of the file with PDB data on the server (relatively to the root directory of the 
Web-server), 
structureId – identifier of a structure 
__STRUCTURE 
 
 ALIGNMENT__ 
The list of alignments can be empty. A single string corresponds to a single alignment. 
A string has the following appearance: 
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structure1 chain1 structure2 chain2 file 
where: 
structure1 – identifier of the first structure in alignment (must be the same as one in 
STRUCTURE block) 
chain1 – strand for the first structure, 
structure2 – identifier of the second structure in alignment (must be the same as one in 
STRUCTURE block) 
chain2 – strand for the second structure, 
file – name of the file with alignment on the server (relatively to the root directory of the 
Web-server) (description of the format see in chapter 1.3.2). 
 
 __ALIGNMENT 
 
Example: 
/******Example start here**************/ 
STRUCTURE__ 
  /var/www/tmp/prot.CgqAd5 1hba 
  /var/www/tmp/prot.CgqAd6 1hbb 
__STRUCTURE 
ALIGNMENT__ 
  1hba B 1hbb A /var/www/tmp/prot.CgqAd7 
__ALIGNMENT 
/******Example end here**************/ 

1.2.3.2. Format of alignment 
HEADER__ 
SOURCES__ 
FILE1: - file with the first structure 
FILE2: - file with the second structure 
CHAIN1: identifiers of the first strand 
CHAIN2: identifiers of the second strand 
SIZE1: length of the first strand (including gaps) 
SIZE2: length of the second strand (including gaps) 
__SOURCES 
__HEADER 
ALIGNMENT__ 
Strings of alignment in the following manner: 
{Position on sequence1} {aligned sequence1 segment} 
{Position on sequence2} {aligned sequence2 segment} 
__ALIGNMENT 
 
Example: 
 
/******Example start here**************/ 
HEADER__ 
SOURCES__ 
FILE1: /usr1/apache/tmp/cce.zjmRVT 
FILE2: /usr1/apache/tmp/cce.cnHbQL 
CHAIN1: B 
CHAIN2: A 
SIZE1: 146 
SIZE2: 141 
__SOURCES 
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__HEADER 
ALIGNMENT__ 
2 HLTPEEKSAVTALWGKV--NVDEVGGEALGRLLVVYPRTQRFFESFGDLSTPDAVMGNPKVKAHGKKVLG 
1 VLSPADKTNVKAAWGKVGAHAGEYGAEALERMFLSFPTTKTYFPHFDL------SHGSAQVKGHGKKVAD 
 
70 AFSDGLAHLDNLKGTFATLSELHCDKLHVDPENFRLLGNVLVCVLAHHFGKEFTPPVQAAYQKVVAGVAN 
65 ALTNAVAHVDDMPNALSALSDLHAHKLRVDPVNFKLLSHCLLVTLAAHLPAEFTPAVHASLDKFLASVST 
 
140 ALAHKYH 
135 VLTSKYR 
__ALIGNMENT 
/******Example end here**************/ 

1.3. Loading the application 
During the loading, on the main window background the information windows with 
reports on current loading and data processing steps (fig.1.3.1) appear. 
If size of loading molecule exceeds the recommended one, then “Model options” dialog 
window appears. This window allows the number of displayed elements to be reduced 
(dialog description see in chapter 3.5 «Selecting the displayed elements of model»). 
 

 

 
Figure 1.3.1. 

 

1.4. Java3D Installation  
Java3D Installation page 2 steps: 
1) In order to run Java3D on your computer, you need to have Java SDK (or JRE) 
installed. For more information on installing Java, see Sun's Java installation site. The 
instructions below concern Runtime Environment (RE) of Java3D only. If you want to 
download Java3D SDK, the procedures for downloading and installation are basically 
the same except that you have to choose SDK files instead of RE files. If you have 
installed the SDK, you have to install RE in order for Java3D function to function 
properly. 
2) Install Java3D with DirectX or Java3D with openGL. 
 
Operation System Home page Download from 

Softberry 
Installation 
instruction 

Windows Sun Java3D site Download Sun installation 
instructions

Solaris Sun Java3D site Download Sun installation 
instructions

Linux Runtime Environment
Blackdown Java3D site

Download README file on 
Blackdown site

 
Windows 

 
1) Download the appropriate Java3D runtime environment.  
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http://java.sun.com/j2se/1.3/
http://www.java.sun.com/products/java-media/3D/download.html
http://www.softberry.com/j3d/java3d-1_2_1_04-win32-opengl-rt.exe
http://www.java.sun.com/products/java-media/3D/java3d-install.html
http://www.java.sun.com/products/java-media/3D/java3d-install.html
http://www.java.sun.com/products/java-media/3D/download.html
http://www.softberry.com/j3d/java3d-1_2_1_04-solsparc-rt.bin
http://www.java.sun.com/products/java-media/3D/java3d-install.html
http://www.java.sun.com/products/java-media/3D/java3d-install.html
ftp://ftp.tux.org/pub/java/java3d/1.2/i386/java3d1_2-FCS-linux-i386-re.tar.bz2
http://www.blackdown.org/java-linux/jdk1.2-status/java-3d-status.html
http://www.softberry.com/j3d/java3d-re-1.2.1_03-fcs-linux-i386.bin
http://www.blackdown.org/java-linux/jdk1.2-status/README-3D121_01
http://www.blackdown.org/java-linux/jdk1.2-status/README-3D121_01


2) Run the executable by double-clicking on the file you downloaded. You can remove 
this file after installation.  
3) You will also need DirectX and/or OpenGL installed on your computer.  
 

Solaris 
 
1) Download the appropriate Java3D runtime environment.  
2) Run the executable. From the directory in which you installed Java3D, type the 
command: 
java3d-1_2_1_01-solsparc-rt.bin
 
You can remove this file after installation.  

Linux 
 
1) Download Runtime Environment.  
2) Move the file to the top level directory of the J2RE in which you wish to install 
Java3D, and go into this directory. Extract the file with:  
bzip2 -dc ~/java3d-1.2.1_01-fcs-linux-i386-re.tar.bz2 | tar xvf -  
3) After installation, you can remove the tar ball. 
4) In order to run Java3D successfully, you should have one of the following system 
configuration:  
 

o XFree86 3.3.6 with Mesa 3.1 or later  
o XFree86 4.0.3 or later with XFree86's Mesa library and DRI  

 (you can setup Mesa library from your Linux ditribution)  
o XFree86 4.0.3 with NVidia drivers 1.0-1251 or later  
o XFree86 4.0.3 with an official (ie. not XFree86's) Mesa library (- see 

http://www.mesa3d.org/).  
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2. General description of the program 
2.1. Main window 

The 3D-Explorer main window consists of the following elements (Fig. 2.1.1): 
• Main menu 
• Toolbar 
• Main view area 
• Auxiliary view area 
• Information panel 
• Status bar 
 

Main window 

Figure 2.1.1. 
1. Main menu. 2. Toolbar. 3. Main view area. 4. Auxiliary view area. 5. Information 
panel. 6. Status bar. 

2.2. Main menu commands  
The File menu contains the following commands: 

• Exit – Quit the program. 
 
The View menu has the following commands for customizing the model view: 

• Detail level – Select the following detail levels for the model: 
o Very low 
o Low 
o Normal 
o High 
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o Very high 
o Custom –user defined quality (this parameter is to be defined in 

«Options» dialog window, see Section 3.6). 
• Display style – Open the Display options dialog window to customize 

the geometry and color settings for the model. 
• Light options – Open the Light options dialog window to customize 

settings for lighting the model. 
• Colors – Open the Periodic table dialog window to select colors for 

particular chemical elements.  
• Model options – Open the Model Options dialog window to select the 

types of atoms, chains, aminoacid residues, and chemical elements to be 
displayed in the model. 

• Options – Open the Options dialog window to customize the general 
view of the model and mouse settings. 

 
The Window menu has the following options: 

• Tree dialog – Display the Tree dialog window to view the hierarchical structure 
of the molecular elements. 

• Sequence viewer – Open the Sequence viewer dialog window to display 
sequences of protein chains. 

• Matrix dialog – Open the Matrix dialog window to display specific features of the 
molecular structure as a matrix diagram. 

 
The ? menu has the commands: 

• Help – Refer to Help Topics. 
• About – Open the About dialog window with information about the program 

(Fig. 2.2.1). 
 

 

 
Figure 2.2.1. 

 

2.3. Toolbar 
The 3D-Explorer toolbar has the following buttons (Click the button … to…): 
 

 Display options - Open the Display options dialog window to customize the 
geometry and color settings for the model. This button corresponds to the 
View>Display style menu command. 

 Light options – Open the Light options dialog window to customize settings for 
lighting the model. This button corresponds to the View>Light options menu 
command. 

 Color options –Open the Periodic table dialog window to select colors for 
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specific chemical elements. This button corresponds to the View>Colors menu 
command. 

 Reset model position – Resets the initial model position. 

 Fit model to screen – Change the model size to fit the view area. 

 Select rotation center mode – When this mode is enabled, the user can assign 
an atom to be the rotation center for the entire model. 

 Reset rotation center – Reset the rotation center at the geometrical center of the 
model. 

 Select mode on/off – Enable/disable selection mode. 

 Normal selection mode – In normal selection mode, each subsequent selection 
unselects the previously selected item. 

 OR selection mode – In OR selection mode, all subsequent selections are 
added to the previously selected items. 

 XOR selection mode – In XOR selection mode, a previously selected item is 
unselected by subsequent selection. 

 Inverse selection – Invert a selection. 

 Select all – Select all elements of the model. 

 Unselect all – Unselect all elements of the model. 

 Model options – Open the Model Options dialog window to select the types of 
atoms, chains, aminoacid residues, and chemical elements to be displayed by the 
program. This button corresponds to the View>Model options menu command. 

 Options – Open the Options dialog window to customize the general view of the 
model and mouse settings. This button corresponds to the View>Options menu 
command. 

 Tree model dialog – Open the Tree dialog window to view the hierarchical 
structure of the model elements. This button corresponds to the Window>Tree 
dialog menu command. 

 Sequence viewer – Open the Sequence viewer dialog window to display 
sequences of protein chains. This button corresponds to the Window>Sequence 
viewer menu command. 

 Matrix viewer – Open the Matrix dialog window to display specific features of the 
molecular structure as a matrix diagram. This button corresponds to the 
Window>Matrix dialog menu command. 

 Help – Refer to Help Topics. This button corresponds to the ?>Help menu 
command. 

 
Comment. Place your mouse pointer over a toolbar button to see the function of this 
button in the status bar (Fig. 2.1.1). 

2.4. Model view areas 
On the main area a model is displayed in selected display mode, on the auxiliary 

one – just in schematic view. The auxiliary area is purposed for changing a model’s 
position as well as a distance to it. In the auxiliary area, the moving, rotating and 
changing a distance to model occur much quicker, that is very important at working with 
models, which contain a large number of atoms. Results of operations, performed on a 
model’s image in the auxiliary area, are to be applied to model’s image in the main area, 
and vice versa. 

Use the Options dialog window to change the background color of the view area 
(see Section 3.6). 
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You can move the border between the view area and the information panel by 
dragging it with your mouse. 

 
2.4.1.1. Shortcut menu 

To open a shortcut menu (Fig. 2.4.1), right-click the view area. The shortcut menu 
includes the following items: 
• “Select atom” – Select the atom you are pointing to with your mouse. 
• “Select residue” – Select the residue you are pointing to with your mouse. 
• “Select chain” – Select the chain you are pointing to with your mouse. 
• “Select molecule” – Select a molecule.  
• “Select all”  – Select all models. 
• “Unselect atom”  – Deselect an atom. 
• “Unselect residue”  – Deselect a residue. 
• “Unselect chain”  – Deselect a chain. 
• “Unselect molecule”  – Deselect a molecule. 
• “Unselect all”  – Deselect all models. 
 

View area shortcut menu 

 
Figure 2.4.1. 

 

2.5. Information panel 
The information panel (Fig. 2.1.1) displays: 

• Information about the atom you are pointing to with your mouse: atom name, 
chemical element, number of the atom in the PDB file, and the name of the 
residue this atom belongs to. 

• Information about the residue you are pointing to with your mouse: residue name, 
chain identifier, type of the secondary structure.  

 

2.6.Status bar 
The status line (fig.2.1.1) is purposed for displaying current information. In this line, the 
function of control panel button, currently pointed by the mouse cursor, the current 
mouse operation mode, the current detailing level and the information on selection are 
displayed. 
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3. Working with the system 
3.1. Working with images 

3.1.1. Customizing image parameters 

3.1.1.1. Adjusting image quality 
To change the image quality, do one of the following: 
• Click View>Detail level in the main menu and select one of the following 

options: 
o Very low 
o Low 
o Normal 
o High 
o Very high 
o Custom – The quality set by the user (the given parameter is set in a 

dialogue window "Options", the description of dialogue see Section 3.6). 
• Change the Detail level parameter in the Options dialog window (see Section 

3.6). 

3.1.1.2. Customizing the view 
Display options dialog window can be opened by: 
• View>Display style command of the main menu. 
• The  toolbar button. 

The Display options dialog window has two tabs:  Atom and Protein. If any of the 
scene elements are selected, changes will be applied only to the selected elements. If 
no elements are selected, changes will be applied to all the scene elements. 
 

Tab Atom  
Tab Atom (fig. 3.1.1.2.1) is used for setting up the displaying parameters for atoms 

of a model: 
Display style panel provides the possibility to choose the view of a model or of a 
selected part of model: 

• Off – To turn off the atoms’ displaying. 
• Line – The wire (skeletal) model. Bonds between atoms are shown as 

lines. 
• Stick – The cylindrical model. Bonds between atoms are shown as 

cylinders. Diameter of cylinders is to be defined in Stick size field. 
• Ball and Stick – The hinged model. Atoms are shown as spheres and 

bonds between atoms as cylinders. Diameter of cylinders is to be defined 
in Stick size field, and radius of spheres – in Ball size one. 

• CPK – The complete atomic model (space-filling). Radiuses of spheres 
are proportional to van der Waals radiuses of atoms. The scale of spheres 
is to be defined in CPK scale field. 

Color panel provides the possibility to choose the color scheme that is to be applied to 
atoms’ view. 

Upon selecting Scheme option, the list with following color schemes becomes 
active: 

• By Element – The color of atom depends on chemical element. 
• By Chain – The color of atom depends on chain it belongs to. 
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• By Residue – The color of atom depends on residue it belongs to. In this case, 
the term «residue» is applied to any group of covalently bound atoms 
(aminoacidic residues, nucleotides, heterogroups). 

• By Amino Acid – The color of atom depends on amino acid it belongs to. 
• By Structure – The color of atom depends on structure it belongs to. 
• By Groups – The color of atom depends on its belonging to either main protein 

strand or side ones. 
Upon selecting Custom option, the color button purposed for choosing the user-defined 
color of model or selected part of model becomes active. Upon pressing this button, 
Color dialog window (see chapter 3.7), in which a desired color can be chosen, 
appears. 
 

The Display options dialog window. The Atom tab. 

 
Figure 3.1.1.2.1. 

1. Model’s view selection panel. 2. Color scheme selection panel. 3. Entry field for 
diameter of cylinders. 4. Entry field for radius of spheres in hinged model. 5. Entry field 
for scale of spheres in complete atomic model. 6. Button for closing the window and 
applying of selected options. 7. Button for closing the window and rejecting of selected 
options. 8. Button for applying of selected options without closing the window. 
 

Tab Protein  
Tab Protein (fig. 3.1.1.2.2) provides the possibility to set up the parameters of model’s 
displaying that are specific for protein molecule. Options of Protein tab can be applied 
to whole chain only. 

Comment. If among the selected elements of a model there is at least one whole 
chain then tab is active. If not all daughter elements of a chain are selected (i.e. chain is 
selected just partially) then “Protein” tab is inactive. If one chain is selected completely, 
but another one – just partially then tab’s options will be applied to the completely 
selected chain only. 

 
Display style panel provides the possibility to choose the style of strands’ displaying: 
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• Off – To turn off the displaying. Upon selecting this option, chains stops to 
be displayed. 

• CA Wire – Сα-atoms along the chain are bound by lines. 
•  CA Stick – Сα-atoms along the chain are bound by cylinders. Diameter 

of cylinders is to be defined in Stick size field. 
• Line ribbon – The protein molecule is shown as lines corresponding to 

the main chain direction. 
• Flat ribbon – The protein molecule is shown as flat ribbon corresponding 

to the main chain direction. 
• Solid ribbon – The protein molecule is shown as volumetric ribbon 

corresponding to the main chain direction. 
• Schematic – The structure of molecule is shown in accordance to the 

following rules: α-helices are shown as wide cylinders, β-folds as arrows, bends 
and unknown structures as narrow cylinders (pipes). 

 
 

The Display options dialog window. The Protein tab. 

 
Figure 3.1.1.2.2. 

1. Panel for selecting the protein chain view style. 2. Panel for selecting the color 
scheme. 3. Entry field for cylinder’s diameter definition in “CA Stick” option. 4. Checkbox 
for turning off the model’s atoms displaying. 5. Button for closing the window and 
applying of selected options. 6. Button for closing the window and rejecting of selected 
options. 7. Button for applying of selected options without closing the window. 
 
Color panel provides the possibility to choose the color scheme to be applied to chains’ 
view. 

Upon selecting Scheme option the list with following color schemes becomes 
active: 

• By Chain – every chain has its own color. 
• By Residue – The color of chain’s part depends on color of residue. In this case, 

the term «residue» is applied to any group of covalently bound atoms 
(aminoacidic residues, nucleotides, heterogroups). 
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• By Amino Acid – The color of chain’s part depends on color of amino acid. 
• By Amino Acid Hydrophobicity – The color of chain’s part depends on its 

hydrophobic properties. 
• By Amino Acid pKa – The color of chain’s part depends on pKa value of amino 

acid. 
• By Structure – The color of chain’s part depends on structure it belongs to. 
• By Secondary structure – The color of chain’s part depends on its secondary 

structure. α-helices are shown in red color, β-folds in blue color, bends and 
unstructured parts in white one. 

Comment. On Flat ribbon and Solid ribbon modes selecting, By Secondary 
structure color scheme is being set automatically. 

On Custom mode selecting, the colored button, purposed for choosing the user-
defined color of a model, becomes active. Upon pressing this button, Color dialog 
window (see chapter 3.7), in which a desired color can be chosen, appears. 

Hide atoms checkbox. If checkbox checked in, the model’s atoms displaying is off. 
Comment. Button OK is purposed for closing the window and applying the selected 

options, button Apply - for applying the selected options without closing the window, 
button Cancel - for closing the window and rejecting of selected options. 

 
3.1.2. Light options 

To open the Light options dialog window (Fig. 3.1.2.1), do one of the following: 
 

The Light options dialog window 

 
Figure 3.1.2.1. 

1. Sliders. 2. Upper left source. 3. Lower left source. 4. Upper right source. 5. Lower 
right source. 6. Front source. 7. Background source. 8. The OK button applies changes 
and closes the dialog window. 9. The Cancel button closes the dialog window and 
cancels changes. 

 
• Select View>Light options in the main menu. 
• Click the  toolbar button 

3D-Explorer allows the user to choose between six light sources that can be 
selected by checking the corresponding boxes:  

• Top-Left – the light source is placed on the left above the model. 
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• Bottom-Left – the light source is placed on the left below the model. 
• Top-Right – the light source is placed on the right above the model. 
• Bottom-Right – the light source is placed on the right below the model. 
• Front – the light source is placed in front of the model. 
• Back –the light source is placed behind the model. 

 
3.1.3. Selecting colors of chemical elements  

You can change the colors of chemical elements in the Periodic Table dialog 
window (Fig. 3.1.3.1). To open this dialog box: 

• Select the View>Colors command in the main menu. 
• Click the  toolbar button. 
 
 

The Periodic table dialog window 

Figure 3.1.3.1. 
1. Buttons for changing the colors of chemical elements. 2. The Close button. 3. The 
Apply button. 4. The Restore button. 
 

The Periodic table dialog window contains colored buttons that are used to 
customize the colors of chemical elements. Each color corresponds to a certain 
element. 

Click a colored button with the name of a chemical element to open a dialog 
window for this specific element, for example, “NITROGEN” (Fig. 3.1.3.2): 
• The Color button shows the current color of the element. After you click this button, 

the Color dialog window will appear on your screen (see Section 3.9). In this dialog 
window, change the color of a chemical element. The Color button will change its 
color, too. Click OK to close the dialog box and apply changes. In the Periodic table 
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dialog window, the button with the name of the chemical element will be colored 
according to the changes you made. 

• The VDW Radius field contains the default value of the van der Waals radius of a 
chemical element. This value can be changed by the user. If you click OK in this 
dialog window and then click either the Close or Apply buttons in the Periodic table 
dialog window, the model will be changed according to the new parameters. 

Dialog window control buttons: 
• Close – Apply changes and close the dialog window. 
• Apply – Apply changes and leave the dialog box window. 
• Restore – Reset the default values of the van der Waals radii of the elements and 

default colors. 
 

The NITROGEN dialog window 

 
Figure 3.1.3.2. 

1. The button for adjusting the color of the chemical element. 2. The VDW Radius field 
for changing the default van der Waals radius of the element. 3. The OK button applies 
changes and closes the dialog window. 4. The Cancel button closes the dialog window 
and cancels changes. 
 

3.2. Model motions 
3.2.1. Moving the model   

To move the model, drag the molecule image over the view area with your 
mouse while pressing the Ctrl key on your keyboard. 

3.2.2. Rotating the model   
You can rotate the model using your mouse. The rotation speed is adjusted in 

the Options dialog window (see Section 3.6). 
By default, the model turns around its geometrical center. You can change the 

geometrical center of the model. To set another geometrical center: 
1. Enable the center selection mode by clicking the  toolbar button. After this, 

the current geometrical center will be selected. 
2. Click the atom you want to set as a geometrical center. The new geometrical 

center will be selected in the view area. 
3. Disable the center selection mode by clicking the  toolbar button. 

  
3.2.3. Changing the distance to the model 

You can change the distance to the model using your mouse while pressing the 
Shift key on your keyboard. If the mouse pointer is moving downwards, the model is 
zoomed out; if the mouse pointer is moving upwards, the model is zoomed in. The 
scaling speed is adjusted in the Options dialog window (see Section 3.6). 

Comments. To load the initial image of the model, click the  toolbar button. 
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To make the model fit the view area, click the  toolbar button. 

3.3. Selecting elements of the model 
You can select specific elements of the model by using your mouse. The 

selection mode is enabled by clicking the  toolbar button.  
When the  toolbar button is switched on, the following buttons become 

available: 
 – Normal selection mode – In this mode, each subsequent selection 

unselects the previously selected item. 
 – OR selection mode – In this mode, all subsequent selections are added to 

the previously selected items. 
 – XOR selection mode – In this mode, a previously selected item is 

unselected by subsequent selection. 
 
Click the  toolbar button to invert a selection.  
Click the  toolbar button to select all elements in the model. 
Click the  toolbar button to unselect all elements of the model. 
 
Comment. The elements of models can also be selected using the Tree dialog and 
Sequence viewer dialog windows (see Section 3.4). 
 

3.4. Lists of model elements 

3.4.1. Hierarchical tree 
The Tree dialog window (Fig. 3.4.1.1) contains the hierarchical tree of the 

elements of a model that can be generated by: 
• Selecting the Window>Tree dialog option in the main menu. 
• Clicking the  toolbar button. 

The Tree explorer dialog window contains the following elements: 
• Control panel 
• List of model elements 
• Dialog window control buttons. 

Control panel buttons 
 – Expand the tree branch to the molecule level. 

 – Expand the tree branch to the chain level. 
 

 – Expand the tree branch to the residue level. 

 – Expand the tree branch to the atom level. 
 – Enable the normal selection mode in which each subsequent selection unselects 

the previously selected item. To select an item, click it with your mouse. 
 – Enable the OR selection mode in which all subsequent selections are added to 

the previously selected items. To select an item, click it with your mouse. 
 – Enable the XOR selection mode in which a previously selected item is unselected 

by subsequent selection. To select an item, click it with your mouse. 
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 - Invert a selection. 
 – Select all elements in the tree. 
 – Unselect all elements in the tree. 

 - When button is pressed, selecting of elements becomes immediately applied to 
model’s displaying in display areas, and Apply and Cancel buttons becomes inactive. If 
button is released, selecting becomes applied on pressing OK or Apply buttons only 
 

The Tree dialog window 

 
Figure 3.4.1.1. 

1. Control panel. 2. Tree of model elements. 3. The OK button. 4. The Apply button. 
5. The Cancel button. 

 
Tree of model elements 

The tree shows the hierarchical structure of model elements. You can select 
elements in the tree with your mouse. Change the selection modes by clicking the 
control panel buttons. 

Junctions containing at least one selected daughter element are marked in green. 
 Selected elements are marked in blue. If all daughter elements of a junction are 
selected, then this junction is also marked in blue. If junction is selected, its daughter 
elements are marked in blue. 
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Dialog window control buttons 
• Click OK to apply selections and close the dialog window. 
• Click Apply to apply selections and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel the current selections. 

3.4.2. Sequence viewer dialog window 
 You can open the Sequence viewer dialog window (Fig. 3.4.2.1) 

designed to view sequences of protein chains by: 
• Selecting the Window> Sequence viewer option in the main menu; 
• Clicking the  toolbar button. 
 

3.4.2.1. Structure of the Sequence viewer dialog window 
The Sequence viewer dialog window contains: 
• Control panel 
• Sequence view area 
• Dialog box control buttons 
• Status bar 

Control panel 
The control panel buttons have the following functions: 

 – Normal selection mode. In this mode, each subsequent selection unselects the 
previously selected item. To select an item, click it with your mouse or select a 
rectangular area with your mouse pointer. 

 – OR selection mode. In this mode, all subsequent selections are added to the 
previously selected items. To select an item, click it with your mouse or select a 
rectangular area with your mouse pointer. 

 – XOR selection mode. In this mode, a previously selected item is unselected by 
subsequent selection. To select an item, click it with your mouse or select a rectangular 
area with your mouse pointer. 

 – Rectangle area selection mode. In this mode, the program selects all residues 
within a rectangular area defined by the motion of your mouse. 

 – Lines selection mode. In this mode, the program selects all residues located in 
the rows you select by moving your mouse. 

 – Columns selection mode. In this mode, the program selects all residues located 
in the columns you select by moving your mouse. 

  – Options. Click this button to open the Options dialog window (see Section 
3.4.2.2) of the Sequence viewer dialog window. 

 – Hide or show elements. Click this button to open the Visible and hidden 
elements dialog window in which you can enable/disable some models to be displayed 
in the sequence view area (see Section 3.4.2.3). 

 – Hide or show headers of elements. In this mode, model names are shown 
above chain sequences. 

 – Select all. Select all elements in the list. 
 – Deselect all. Deselect all elements in the list. 

In the upper right corner of the dialog box there is an input field Sequence used 
to search for specified fragments (templates) in chains. Enter a sequence into the field 
and press Enter. The fragment found will be highlighted in another color (Fig. 3.4.2.1). 

 19



Sequence view area 
The sequence view area shows chain sequences in one-letter code (Fig. 

3.4.2.1). You can select residues within this view area. In the Options dialog window 
(see Section 3.4.2.2), you can change selection modes and color patterns for the 
sequence view area, including the background color. Note that selection modes can 
also be customized on the control panel. A residue marked with a red underscore 
belongs to an α-helix and that with a blue underscore, to a β−structure. 

On the left side of the area you can see chain identifiers selected for viewing. 
The names of chains containing recently selected residues are highlighted (the 
highlighting color is set in the Options dialog window). The background color of chain 
names is customized in the Options dialog window. If you click the chain name, the 
entire sequence will be selected. 

The residues you are pointing to with your mouse is highlighted with a user-
defined color (Fig. 3.4.2.1). 

 
The Sequence viewer dialog window 

 
Figure 3.4.2.1. 

1. Control panel. 2. Search result. 3. Sequence view area. 4. Mouse cursor position in 
the sequence view area (the residue is highlighted in blue). 5. Model name. 6. Chain 
identifiers. 7. Status bar. 8. The OK button. 9. The Apply button. 10. The Cancel 
button. 

 
Dialog window control buttons: 

• Click OK to apply selections and close the dialog window. 
• Click Apply to apply selections and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel the current selections. 

Status bar 
The status bar shows: 

• Information about the residue you are pointing to with your mouse: residue name in 
three-letter code and its number in the PDB file (Fig. 3.4.2.1). 

3.4.2.2. Options window of the Sequence viewer dialog window 
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Dialog window elements 
To open the Options dialog window, click the  control panel button in the 

Sequence viewer dialog window. The Options window has two tabs: the Common tab 
(Fig. 3.4.2.2.1) which allows you to adjust selection modes for the Sequence viewer 
dialog window and the Colors tab (Fig. 3.4.2.2.2) which serves to customize the colors 
of selected residues. 

 
Common tab 

• On the Symbol selection mode panel, you can set the following selection modes: 
o Normal mode – In this mode, each subsequent selection unselects the 

previously selected item. 
o OR mode – In this mode, all subsequent selections are added to the 

previously selected items. 
o XOR mode – In this mode, a previously selected item is unselected by 

subsequent selection. 
 

The Common tab 

 
Figure 3.4.2.2.  

1. The Symbol selection mode panel. 2. The Area selection style panel. 3. Select 
after mouse release only checkbox.  4. Show horizontal grid checkbox. 5. Show 
vertical grid checkbox. 6. Leave partial selection during apply checkbox. 7. Button 
for setting of the Sequence view area font. 8. The OK button. 9. The Cancel button.10. 
The Apply button.  
 
• On the Area selection style panel, you can change the style of selecting residues in 

the selection view area: 
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o Rectangle mode – In this mode, you select a rectangular area while 
moving your mouse. All residues within this area are automatically 
selected. 

o Rows selection mode – In this mode, you select all residues in a row 
while moving your mouse. 

o Columns selection mode – In this mode, you select all residues in a 
column while moving your mouse. 

• Checkbox Apply immediately. If checkbox checked in, selection becomes 
applied to a model immediately after releasing the mouse button. If checkbox 
checked out, selection becomes applied on pressing OK or Apply buttons of 
Sequence viewer dialog window only. 

• Checkbox Select after mouse release only. Not active in the current version. 
• Checkbox Show horizontal grid. If checkbox checked in, then in area of amino 

acid sequences visualization the horizontal separator lines are shown (fig. 
3.4.2.1). If checkbox checked out, the horizontal separator lines are not shown. 

• Checkbox Show vertical grid. If checkbox checked in, then in area of amino 
acid sequences visualization the vertical separator lines are shown (fig. 3.4.2.1). 
If checkbox checked out, the vertical separator lines are not shown. 

• Checkbox Leave partial selection during apply. If checkbox checked in, then 
partial selection of amino acids is being kept on applying a new one. 

• Button Font is purposed for choosing a font of chains’ and aminoacidic 
sequences’ names. On pressing this button, Font dialog window, purposed for 
choosing a font (see chapter 3.9), appears. 

 
Colors tab   

• On the Background color panel, you can select a background color for the 
sequence view area. The color of the button is the current background color. When 
you click this button, the Color dialog window appears on your screen. In this dialog 
window, you can select a background color (see Section 3.7 about the Color dialog 
window). 

• On the Applied selection color panel, you can select a color for applied selections. 
The button displays the current color. When you click this button, the Color dialog 
window appears on your screen. In this dialog box, you can select a color for applied 
selections (see Section 3.7 about the Color dialog window). 

• Panel Partial selection is purposed for choosing a color of residue that is selected 
partially (i.e. not all of atoms of residue are selected). The color of button 
corresponds to current color. On pressing the button, Color dialog window for color 
choosing appears. Operating this window is described in chapter 3.7. 

• On the Chain background panel, you can select a background color for the names 
of the chains. The color of the button is the current background color. When you 
click this button, the Color dialog window appears on your screen. In this dialog 
box, you can select a background color (see Section 3.7 about the Color dialog 
window). 

• On the User selection color panel, you can select a color for new selections. The 
button displays the current color of new selections. When you click this button, the 
Color dialog window appears on your screen. In this dialog window, you can select 
a color for applied selections (see Section 3.7 about the Color dialog window). 

• On the Selection of applied panel, you can select a color for sections of overlying 
new and applied selections. The button displays the current color of these sections. 
When you click this button, the Color dialog window appears on your screen. In this 
dialog box, you can select a color for applied selections (see Section 3.7 about the 
Color dialog window). 
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The Colors tab 

 
Figure 3.4.2.3. 

1. The Background color panel. 2. The User selection color panel. 3. The Applied 
selection color panel. 4. The Selection of allied panel. 5. The Partial selection 
panel. 6. The Selection of partial panel. 7. The Chain background panel. 8. The 
Selected chains panel. 9. The Preview field. 5. The User selection field. 6. The User 
selection of applied panel. 7. The Symbol foreground panel. 10. The OK button. 11. 
The Cancel button. 12. The Apply button. 
 
• Panel Selection of partial is purposed for choosing a color of residue that belongs 

to overlapping of partial and new selections. The color of button corresponds to 
current color. On pressing the button, Color dialog window for color choosing 
appears. Operating this window is described in chapter 3.7. 

• Panel Selected chains is purposed for choosing a color of names of chains, 
containing the selected residues. The color of button corresponds to current color. 
On pressing the button, Color dialog window for color choosing appears. Operating 
this window is described in chapter 3.7. 

• In the Preview field, you can preview the customized colors. 
 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Apply to apply changes and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel changes. 
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3.4.2.3. Visible and hidden elements dialog window 
To open the Visible and hidden elements dialog window (Fig. 3.4.2.3.1), click 

the  control panel button in the Sequence viewer dialog window. In the Visible and 
hidden elements dialog window, you can change the content and order of models and 
alignments as they are displayed in the sequence view area of the Sequence viewer 
dialog window. 

To show specific models or alignments, follow these steps: 
1. Select the identifiers of models and alignments in the Hidden list by clicking your 

mouse (if you want to unselect a selected identifier, click it with your mouse). 

2. Click the  button. After this, the selected identifiers will be removed from the 
Hidden list and added to the end of the Visible list in the same order as they 
were arranged in the Hidden list. 

To include all models (and alignments) in displaying it is necessary to press  
button. All identifiers will be removed from «Hidden» list to «Visible» one in the same 
order. 

The Visible and hidden dialog window 

 
Figure 3.4.2.3.1. 

1. The button for moving the selected models upwards.  2. The button for moving the 
selected models downwards.  3. The button for showing selected models. 4. The button 
for showing all models. 5. The button for hiding all models. 6. The button for hiding 
selected models. 7. The Visible list. 8. The Hidden list. 9. The OK button. 10. The 
Cancel button. 11. The Apply button.  

 
To hide some models, follow these steps: 
1. Select the corresponding model identifiers and alignments in the Visible list by 

clicking your mouse (if you want to unselect a selected identifier, click it with your 
mouse). 
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2. Click the  button. After this, the selected identifiers will be removed from the 
Visible list and added to the end of the Hidden list in the same order as they 
were in the Visible list. 
To exclude all models (and alignments) from displaying it is necessary to press 

 button. All identifiers will be removed from «Visible» list to «Hidden» one in the 
same order. 

 
To change the order of models in the lists, click the Up or Down buttons to shift a 

model one step below or above.  
 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Apply to apply changes and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel changes. 
 

3.5. Selection of elements to be displayed  
Atoms, strands, residues and chemical elements can be selected for displaying 

by using Model options dialog window (fig.3.5.1), which can be opened by one of the 
following means: 

• Using View>Model options command of the main menu. 
• Using  button on the control panel. 

In the information bar the current information on all loaded models as well as on the 
model selected in the dropdown list is displayed: 

1. Total numbers of strands, residues and atoms contained in models and a 
number of atoms included in displaying. 

2. Number of atoms selected for displaying. 
The list of models’ identifiers is purposed for selecting a model, for which the display 
parameters can be changed. 
The panel Proteins is purposed for selection of protein elements that are to be 
displayed: 

Checkbox Protein backbone. If the checkbox checked in, the protein main chain 
is displayed. The chain displaying styles: 

• Trace – only Cα-atoms of a protein are selected. 
• Partial – a part of the protein main chain’s atoms are selected: Cα, N and C. 
• Complete – all atoms of the protein main chain are selected: Cα, N, C and O. 

Checkbox Protein sidechains. If the checkbox checked in, the protein 
sidechains are displayed. 
The panel DNA is purposed for selection of DNA elements that are to be displayed: 

Checkbox Nucleotide backbone. If the checkbox checked in, the sugar-
phosphate chain of DNA is displayed. 

Checkbox Nucleotide bases. If the checkbox checked in, the nucleotide bases 
are displayed. 

Checkbox Solvents. If the checkbox checked in, the solvent’s atoms are 
displayed. 

Checkbox Heterogenes. If the checkbox checked in, the heteroatoms are 
displayed. 

Buttons Atoms, Chains, Residues, Elements and Models call the appropriate 
dialog windows with lists of displayed atoms, chains, residues, chemical elements and 
models (fig.3.5.2). 
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The Model options dialog window 

 
Figure 3.5.1. 

1. Information bar. 2. Panel for selection of protein elements that are to be displayed. 3. 
Panel for selection of DNA elements that are to be displayed. 4. Panel for opening the 
lists of displayed elements of a model. 5. List of loaded models. 6. Button for closing the 
window and confirmation of the choice. 7. Button for closing the window and refusing of 
the choice. 
 

In Atoms, Chains and Models dialog windows (3.5.2 A, C, D, E) it is necessary 
to select elements or models to be displayed. For these purposes, click the mouse 
button over a status indicator, which is located to the left of name of element. If a black 
square appeared on indicator ( ), then element is selected for displaying, otherwise 
( ), it is excluded from displaying (fig.3.5.2). 
In the Atoms dialog window, the buttons of the control panel above the list allow to 
include into displaying the following groups of atoms: 

• The button  – all atoms in the list. 

• The button  – atoms of the main protein chain: Cα, N, C and O. 
• The button  – the part of atoms of the main protein chain: Cα, N, and C. 

• The button  – Cα- atoms of the main protein chain only. 

 26



• The button  – pressing of the button excludes the hydrogen atoms from 
displaying. 

 
 

 
A 

 
 
 
 

B 

 
 

C 
 

D 

 
E 

Figure 3.5.2. 
A. Atoms dialog window. B. Residues dialog window.  C. Chains dialog window. D. 
Elements dialog window. E. Models dialog window. 
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 1. Control panel buttons. 2. Status Bar. 
 
 
The Residues dialog window (3.5.2. B) contains the list of chains’ names with ranges of 
displayed residues for each chain. To change a range, select the name of a chain with 
appropriate range and then press Edit button. A dialog window with the title containing 
the chain’s name (e.g. Chain: А) will appear. In this window, the range of displayed 
residues can be defined (fig.3.5.3). To change a range, enter the required values into 
From and To fields. As soon as Set button on Min bar is pressed, the number of the 
first chain residue is to be entered. Similarly, as soon as Set button on Max bar is 
pressed, the last chain residue is to be entered. 

 
 

 

 
Figure 3.5.3. 

1. Entry field From. 2. Entry field To. 3. Min panel. 4. Max panel. 5. Button of changes 
acceptation and window quit. 6. Rejection button. 

 
Model options dialog window control buttons: 

• Click OK to apply changes and close the dialog window. 
• Click Cancel to cancel changes and close the dialog window. 

 

3.6. Options dialog window 
On the Options dialog window (Fig. 3.6.1), you can set the general parameters of 

the model and mouse parameters. To open the Options dialog window, do the 
following: 

• Select the View>Options option in the main menu. 

• Click the  toolbar button. 
In the Options dialog window, you can change: 

• The distance to the model in the Model scale field. 
• The quality of model images in the Detail level field. For example, the value 2 

corresponds to the Very low detail level (also set by clicking the View->Detail 
level->Very low option in the main menu), 5 to the Low level, 15 to the Normal 
level, 25 to the High level, and 40 to the Very high level. 

• The sensitivity of rotation to mouse motion adjusted in the Rotation speed field.  
• The sensitivity of scaling to mouse motion set in the Scaling speed field. 
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• The background color of the view area. Click Background button to open the 
Color dialog window and select a background color. See Section 3.7 about the 
Color dialog window. 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Cancel to cancel changes and close the dialog window. 
• Click Apply to accept changes without quit the window. 
 

The Options dialog window 

 
Figure 3.6.1. 

1. The field for entering the distance to the model. 2. Detail level. 3. Rotation speed. 4. 
Scaling speed. 5. The button for selecting the background color for the view area. 
6. The OK button. 7. The Cancel button. 8. The Apply button. 
 

3.7. Color dialog   
The Color dialog window (fig. 3.7.1) provides the color selection. Color can be 

selected by several means: 
• Using the basic colors set. It requires the clicking on the square with desired 

color. The selected color will appear on the new color preview bar. To accept the 
choice press the OK or Apply buttons. 

• Using the customized colors set. It requires the clicking on the square with 
desired color of this set. The selected color will appear on the new color preview 
bar. To accept the choice press the OK or Apply buttons. It’s allowed to change 
the set of colors. It requires the clicking on a square of this set. Using slider and 
switches of HSB and RGB models fields select a desired color. Upon the Set 
Custom Color button is pressed the selected color will appear in a selected 
square of the set and on the new color preview bar. 

• Using the new color selection. For this purpose use the slider and switches of 
HSB and RGB color models fields. The selected color will appear on the new 
color preview bar. To accept the choice press the OK or Apply buttons. 
If it’s required to be back to old color click the mouse on the previous color 

preview bar and press the OK or Apply buttons. 
Comment. The OK button provides the acceptation of changes made and quit 

the window. The Cancel button provides the rejection of changes made and quit the 
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window. The Apply color button provides the acceptation of changes made without quit 
the window. 

 
 

Color dialog window 

Figure 3.7.1. 
1. Color selection area. 2.  Slider. 3. New color preview bar. 4. Previous color preview 
bar. 5. HSB color model. 6. RGB color model. 7. Customized colors. 8. Basic colors set. 
9. Button for color customizing. 10. Button of color acceptation and quit the window. 
11. Button of choice rejection and quit the window. 12. Button of color acceptation 
without quit the window. 

 
 

3.8. Matrix dialog window 

In the Matrix dialog window (Fig. 3.8.1), you can set the program to display 

structural features of models as matrix diagrams. To open the Matrix dialog window, do 
the following:  

• Select the Window>Matrix dialog option in the main menu.  
• Click the  control panel button.  

 The color of each cell in the diagram depends in the value of the corresponding 
matrix element. You can change the type and view mode for your matrices. 

In the Model identifiers drop-and-down list, select the identifier of the model to be 
displayed as a matrix (Fig. 3.8.1). The list contains identifiers of all loaded models. 
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The upper matrix mode can be selected in the drop-and-down list for the upper 
matrix and the lower matrix mode can be selected in the drop-and-down list for the 
lower matrix (Fig. 3.8.1). The following matrix modes are available: 

• Distance – Show distances between matrix elements. 
• Identity – Show similarities between the types of elements. 
The secondary molecular structure is shown on the left and below the matrix. α-helix 

fragments are shown in red, β-structures are blue, and turns and non-structured 
elements are white. 

The status bar displays the following data about the pair of elements marked with 
the mouse pointer in the matrix diagram: the distance between them in the Distance 
mode, their resemblance in the Identity mode.  

Click the Clone button to make a copy of this dialog window. 
 

The Matrix dialog window 

 
Figure 3.8.1. 

1. Model identifiers. 2.  The Clone button. 3. Drop-and-down list for selecting the mode 
for the upper matrix. 4. The drop-and-down list for selecting the mode for the lower 
matrix.  5. Upper matrix. 6. Lower matrix. 7. Secondary structure. 8. Status bar. 
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3.9. Font dialog window 
The Font dialog window (fig. 3.9.1) provides the setting of font parameters.  

• The Font list provides the selection of a desired font. 
• The Font style list provides the selection of the font style. 
• The Size list provides the selection of the font size. 
• The Preview bar provides the preview of selected font.  
• The OK button provides the acceptation of changes made and quit the window. 
• The Apply font button provides the acceptation of changes made without 

quitting the window.  
• The Cancel button provides the rejection of changes made and quit the window. 

 
Font dialog window 

 
Figure 3.9.1. 

1. List of font selection. 2. List of font style selection. 3. List of font size selection. 4. 
Font preview bar. 5. Button of changes acceptation and window quit. 6. Button of 
changes acceptation without window quit. 7. Rejection button.
 
 

4. References 
1. www.rcsb.org/pdb/info.html#File_Formats_and_Standards 
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