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1. Introduction  
3D-Explorer is designed to visualize spatial models of biological macromolecules 

and their complexes (below referred to as models). The 3D-Explorer application is 
compatible with PDB files [1].  

3D-Explorer has an interface compatible with the GetAtoms and CE applications [2, 
3]. 

The macromolecule can be presented as wire, stick, ball and stick, and CPK models.  
Models (or selected parts of models) can be moved, rotated and zoomed in or out. 
You can also change the detail level and color of models and their elements. 
In 3D-Explorer, you can work with several types of molecular elements and show the 

structural features of a molecule as a matrix diagram. 

1.1. Installation procedure for MS WINDOWS Tm 

For installation of 3D-Explorer Trial version, the following steps are required: 
1. Download the archive; 
2. Extract files from archive with full pathways 

To run the application use 3DExplorer.exe file in the “rbin” folder. 
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2. General description of the program 
2.1. Main window 

The 3D-Explorer main window consists of the following elements (Fig. 2.1.1): 
• Main menu 
• Toolbar 
• View area 
• Information panel 
• Status bar 
 

Main window 

Figure 2.1.1. 
1. Main menu. 2. Toolbar. 3. View area. 4. Information panel. 5. Status bar. 
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2.2. Main menu commands 

The File menu contains the following commands: 
• Open – Load a model. 
• Add – Add a model to the scene. 
• Load from PDB – opens “Load from PDB” dialog window, purposed for 

loading of a PDB-file from PDB-server. 
• Open NMR – opens “Open NMR” dialog window, purposed for loading of 

a file with structures, obtained with use of Nuclear Magnetic Resonance. 
• Align 2 3D – opens “Select chains” dialog window, purposed for defining 

the parameters of loaded alignment. 
• Getatoms – opens “Getatoms” dialog window, purposed for loading of 

«GetAtoms» program work results. 
• Exit – Quit the program. 

The View menu contains the set of commands, purposed for working with model’s 
image: 

• Detail level – Select the following detail levels for the model: 
o Very low 
o Low 
o Normal 
o High 
o Very high 

• Animation – Configure the automatic rotation of the model: 
o Spin - enable (disable) the rotation of the model. 
o Set delay – Display the Set delay dialog window where you can 

set the delay for model rotation. 
• Display – Open the Display options dialog window to customize the 

geometry and color settings for the model. 
• Light options – Open the Light options dialog window to customize 

settings for lighting the model. 
• Colors – Open the Color dialog window to select colors for particular 

chemical elements.  
• Model options – Open the Model Options dialog window to select the 

types of atoms, chains, aminoacid residues, and chemical elements to be 
displayed in the model. 

• Options – Open the Options dialog window to customize the general 
view of the model and mouse settings. 

• Fullscreen – Display the view area in full-screen mode. 
• Save scene to Bitmap – opens “Save as” dialog window, purposed for 

saving of the scene image as a graphic file. In order to save an image, 
define the name and graphic format of a file and then press “Save” button. 
Available formats are: bmp, jpeg, gif, png, tiff. 

The Window menu contains the following commands: 
• Tree dialog – Display the Tree explorer dialog window to view the hierarchical 

structure of the molecular elements. 
• Sequence viewer – Open the Sequence viewer dialog window to display 

sequences of protein chains. 
• Matrix dialog – Open the Matrix diagram dialog window to display specific 

features of the molecular structure as a matrix diagram. 
• View PDB file – opens “PDB data” dialog window (fig. 2.2.1), purposed for 

viewing and saving of PDB-file. 
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The PDB data dialog window 

 
Figure 2.2.1.  

1. The list of loaded structures. 2. PDB-file for selected in the list structure. 3. Found 
substring. 4. Entry field for substring to search. 5. Button for closing of the window. 6. 
Button for saving of the PDB-file. 

 
 
The Settings menu has a set of commands for configuring application settings: 

• Network settings – Open the Network settings dialog window (Fig. 2.2.2) to 
configure network settings. 

 
The Network settings dialog window 

 
Figure 2.2.2.  

1. Server address field. 2. Server port field. 3. CE program name field. 4. Getatoms 
program name field. 5. Get data program name field. 6. Click OK to apply changes and 

 5



close the dialog window. 7. Click Cancel to cancel changes and close the dialog 
window. 

 
The ? menu has the commands: 

• Help – Refer to Help Topics. 
• About – Open the About dialog window with information about the program 

(Fig. 2.2.3). 
 

The About dialog window 

 
Figure 2.2.3.  

2.3. Toolbar 

The 3D-Explorer toolbar has the following buttons (Click the button … to…): 
 

 Display options - Open the Display options dialog window to customize the 
geometry and color settings for the model. This button corresponds to the 
View>Display style menu command. 

 Light options – Open the Light options dialog window to customize settings for 
lighting the model. This button corresponds to the View>Light options menu 
command. 

 Color options –Open the Color dialog window to select colors for specific 
chemical elements. This button corresponds to the View>Colors menu 
command. 

 Full screen – Display the view area in full-screen mode. This button corresponds 
to the View>Fullscreen menu command. 

 Reset model position – Resets the initial model position. 

 Fit to window – Change the model size to fit the view area. 

 Select rotation center mode – When this mode is enabled, the user can assign 
an atom to be the rotation center for the entire model. 

 Reset rotation center – Reset the rotation center at the geometrical center of the 
model. 

 To turn on the «transformation» mode. In this mode, the movement, rotation 
and changing of a distance operations can be performed for selected elements of 
scene only. 

 Select mode on/off – Enable/disable selection mode. 

 Normal selection mode – In normal selection mode, each subsequent selection 
unselects the previously selected item. 

 OR selection mode – In OR selection mode, all subsequent selections are 
added to the previously selected items. 

 XOR selection mode – In XOR selection mode, a previously selected item is 
unselected by subsequent selection.  
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 Inverse selection – Invert a selection. 

 Select all – Select all elements of the model. 

 Unselect all – Unselect all elements of the model. 

 Model options – Open the Model Options dialog window to select the types of 
atoms, chains, aminoacid residues, and chemical elements to be displayed by the 
program. This button corresponds to the View>Model options menu command. 

 Options – Open the Options dialog window to customize the general view of the 
model and mouse settings. This button corresponds to the View>Options menu 
command. 

 Tree model dialog – Open the Tree dialog window to view the hierarchical 
structure of the model elements. This button corresponds to the Window>Tree 
dialog menu command. 

 Sequence viewer – Open the Sequence viewer dialog window to display 
sequences of protein chains. This button corresponds to the Window>Sequence 
menu command. 

 Matrix viewer – Open the Matrix diagram dialog window to display specific 
features of the molecular structure as a matrix diagram. This button corresponds 
to the Window>Matrix dialog menu command. 

 Save scene as image – To save the image of scene. It opens the “Save as” 
dialog window, purposed for saving of the scene’s image as a graphics file. 

 Help – Refer to Help Topics. This button corresponds to the ?>Help menu 
command. 

 
Comment. Place your mouse pointer over a toolbar button to see the function of this 
button in the status bar (Fig. 2.1.1). 

2.4. View area 

The view area displays models in the user-defined view mode (Fig. 2.1.1). In the 
view area, you can change the distance to the model, move and rotate models, and 
select fragments of the model. Dashed lines indicate hydrogen bonds. 

Use the Options dialog window to change the background color of the view area 
(see Section 3.7). 

You can move the border between the view area and the information panel by 
dragging it with your mouse. 

2.4.1.1. Shortcut menu 
To open a shortcut menu (Fig. 2.4.1.1.1), right-click the view area. The shortcut 

menu includes the following items: 
• Select all – Select all models. 
• Deselect all – Deselect all models. 
• Select atom – Select the atom you are pointing to with your mouse.  
• Select residue – Select the residue you are pointing to with your mouse. 
• Select chain – Select the chain you are pointing to with your mouse. 
• Select structure – Select the model you are pointing to with your mouse. 
• Deselect atom – Deselect an atom. 
• Deselect residue – Deselect a residue. 
• Deselect chain – Deselect a chain. 
• Deselect structure – Deselect a model. 
• Saved selections – opens the “Saved selections” dialog window, purposed for 

choosing of saved selections (fig. 2.4.1.1.2). A selection must be chosen from the 
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list. The “Set selection” button is used for changing of the current scene’s selection 
to a chosen one. The “Add selection” button is used for adding of the chosen 
selection to the current selection of the scene’s elements. 

 
View area shortcut menu 

 
Figure 2.4.1.1.1. 

 
The Saved selections dialog window 

 
Figure 2.4.1.1.2. 

1. The list of saved selections. 2. Button for changing of the current scene’s selection to 
a chosen one. 3. Button for adding of the chosen selection to the already present in the 
scene ones. 4. Button for closing of the window. 

 
 
• Save selection – opens the “Save selection” dialog window, purposed for saving of 

the current selection (fig. 2.4.1.1.3.). It requires to enter the name of selection and 
press the “OK” button. 

 
The Save selection dialog window 

 
Figure 2.4.1.1.3. 

1. The selection’s name entry field. 2. Button for saving of the selection and closing of 
the window. 3. Button for canceling of the selection’s saving and closing of the window.  
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2.5. Information panel 

The information panel (Fig. 2.1.1) displays: 
• Information about the atom you are pointing to with your mouse: atom name, 

chemical element, number of the atom in the PDB file, and the name of the 
residue this atom belongs to. 

• Information about the residue you are pointing to with your mouse: residue name, 
chain identifier, type of the secondary structure, indices of N- and C- terminal 
residues for the secondary structure this residue belongs to. 

• PDB-identifier of a structure, at which cursor is pointed, or file’s name, from 
which a structure is loaded (in the case of PDB- identifier’s missing). 

2.6.Status bar 

The status bar (Fig. 2.1.1) displays: 
• The function of the toolbar button you are pointing to with your mouse; 
• Selection status. 
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3. Working with the system 
3.1. Loading a model 

3D-Explorer allows the user to load the following models: 
• PDB files. 
• Files created and edited with the GetAtoms program. 
• Alignments created with the CE program. 

When a model is being loaded, you can see an information box that disappears 
after the load is completed (Fig. 3.1.1). 

 
 

 
Figure 3.1.1. 

 
• Load from PDB - opens the Load from PDB dialog window, purposed for 

loading of a PDB-file from the PDB server. 
• Open NMR - opens the Open NMR dialog window, purposed for loading of a file 

with structures, obtained with use on nuclear magnetic resonance. 
• Align 2 3D – opens the Select chains dialog window, purposed for defining of 

the loading alignment’s parameters. 
• Getatoms – opens the Getatoms dialog window, purposed for loading of 

GetAtoms program’s working results. 
3.1.1. Loading a file 

To load a model, click File>Open. In the dialog window that appears on your 
screen, select the file to be loaded. All previously loaded models are deleted from the 
scene. 

3.1.2. Adding a model 
To add a model to the existing ones, click File>Add. In the dialog window that 

appears on your screen, select the file to be added.  
3.1.3. Loading of PDB-file 

The Load from PDB dialog window (fig. 3.1.3.1), purposed for loading of a PDB-
file from the official PDB server (www.pdb.org), can be opened using the File> Load 
from PDB command of the main menu. 
The PDB id field is used for specification of the PDB-identifier.  
Checkbox Add to scene. If the checkbox is checked in, the model is added to scene. If 
checkbox is checked out, the model substituted the scene’s content. 
 
The OK button is used for closing of the window and starting of file’s loading. During the 
file’s loading appears the information window, which disappears on loading is finished 
(fig. 3.1.3.2). 

The Cancel button is used for closing of the window and canceling of file’s 
loading. 
 

The Load from PDB dialog window 
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Figure 3.1.3.1. 

1. ID’s entry field. 2. “Add to scene” checkbox.  3. Button for launching of window’s 
opening and closing. 4. Button for canceling of window’s opening and closing. 

 
 

 
Figure 3.1.3.2. 

 
3.1.4. Loading of NMR-file 

The Open NMR dialog window (fig. 3.1.4.1), purposed for loading of a file with 
structures, obtained with use on nuclear magnetic resonance, can be opened using the 
File>Open NMR command of the main menu. 
The Load structure number option is used for loading of a selected structure. 
The Load all option is used for loading of all structures from the file. 
The File field is used for file’s full name prompting. 
The OK button is used for launching of window’s opening and closing. 
The Cancel button is used for canceling of window’s opening and closing. 

 
The Open NMR dialog window 

 
Figure 3.1.4.1. 

1. Load a certain structure. 2. Load all structures. 3. Path to file. 4. Button for launching 
of window’s opening and closing. 5. Button for canceling of window’s opening and 
closing. 
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3.1.6. Loading GetAtoms files 
Click File>Getatoms in the main menu to open the Getatoms dialog window 

(Fig. 3.1.6.1). In this dialog window, you can calculate the coordinates of side chains of 
amino-acid residues using the coordinates of the atoms in the main chain of the 
template structure performed by the GetAtoms program and load the model obtained. 

Getatoms dialog window interface: 
The Getatoms dialog window consists of three panes where you can enter the following 
data: 

• Coordinates of the atoms in a template chain. 
• Pair alignment of sequences of the calculated and template chains. 
• Calculation parameters. 

 
To specify the coordinates of the atoms in a template chain, do one of the following: 

• In the Enter PDB identifier field, enter the PDB identifier of the template chain 
from the PDB database. In this case, the coordinates in PDB format will be 
loaded from the server. 

• In the Or file in PDB format field, select the PDB file with the user data using the 
Browse… button. 

 
The Getatoms dialog window 

 
Figure 3.1.3.1. 

1. Entry panel for PDB-file of the template strand. 2. Entry field for strand’s ID. 3. Panel 
for defining the parameters of alignment. 4. Panel for defining the parameters of 
calculations. 5. Button for starting calculations and following loading. 6. Button for 
clearing “Enter PDB identifier”, “Or file in PDB format”, “Chain” and “Enter alignment file” 
fields. 7. Button for canceling calculations. 
 
The Chain field serves to specify the identifier of the chain of a template structure. 
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To specify the alignment for sequences of the calculated and template structures, do 
one of the following: 

• Specify a file with the alignment. 
• Insert alignment into the text field. 

The Alignment format drop-and-down list contains four values [2, 3]: 
• LOCAL – Output alignment format of the FOLD program. 
• CE – Output alignment format of the CE alignment application. 
• FASTA – FASTA format 
• SIMPLE – simple format. 

 
To set the calculation parameters, do the following: 
• In the Sa temperature field, enter the value of the annealing temperature. The value 

must be nonzero. 
• In the Sa max. number of steps field, enter the maximum number of annealing 

steps. 
• Check the Add H-atoms in the end of optimization box to add hydrogen atoms. 

The hydrogen atoms are added according to geometry rules; their position cannot be 
optimized. 

Control buttons 
• Click Process to start calculating and load the model. 
• Click Reset to clearing “Enter PDB identifier”, “Or file in PDB format”, “Chain” and 

“Enter alignment file” fields. 
• Click Cancel to cancel the calculation. 

3.1.4. Loading the alignments created in the CE program. 
The Select chains dialog window (Fig. 3.1.3.2) allows you to work with the 

results of the CE program. To open this dialog window, click File>Align 2 3D in the 
main menu. 
 

The Select chains dialog window 

 
Figure 3.1.4.1. 

1. Chain 1 parameters pane. 2. Chain 2 parameters pane. 3. The Process button. 4. 
The Cancel button. 
 

In the Chain 1 and Chain 2 panes, you can specify the following chain 
parameters. 
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Use the Chain ID field to specify the chain identifier. To define the chain identifier, 
do one of the following: 

• Enter the PDB identifier from the PDB database into the PDB field. In this case, 
the PDB file will be loaded from the server. 

• Check the User file option button and select a PDB file with the user data  
Dialog window control buttons 

• Click Process to start calculating and load the model. 
• Click Cancel to cancel the calculation. 
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3.2. Operations with image. 

3.2.1. Setting up the image 

3.2.1.2. Setting up the model’s view 
To open the Display options dialog window, click: 
• View>Display style in the main menu. 
• The  toolbar button. 

The Display options dialog window has two tabs: Geometry and Sizes. If any of the 
scene elements are selected, changes will be applied only to the selected elements. If 
no elements are selected, changes will be applied to all the scene elements. 

Geometry tab 
The Geometry tab (Fig. 3.2.1.2.1) is used to specify the types of geometry for 

the elements of the model. 
The Group column contains the names of groups with adjustable viewing 

parameters: 
• Protein backbone – Protein backbones 
• Protein sidechain – Aminoacid residue side groups 
• Nucleotide backbone – DNA sugar–phosphate backbone 
• Nucleotide base – DNA nucleotide bases 
• Solvent – Solvent atoms 
• Heterogene - Heteroatoms 
• Protein structure – A schematic representation of the protein backbone. 
• Molecule surface – the surface of the protein molecule (atoms of a solvent and 

heteroatoms are not considered on building the surface); 

List Styles for Molecule surface group contains the following options: 
• Vertex surface – the surface is displayed as dots; 
• Wire surface – the surface is displayed as grid. 
• Solid surface – «continuous» surface. 
Radius of a solvent is defined in Solvent radius field, factor of smoothing – in 
Smooth factor field, quality of a surface – in Voxel count field at Surface panel of 
Sizes tab. 
Comment. To build a surface the adopted algorithm «marching cubes» [4] is used. 

The viewing parameters for a group can be adjusted by selecting the required values in 
the following columns:  

• The Modes checkboxes are used to display/hide certain groups in a model. For 
the Protein backbone group, select an appropriate value from the drop-and-
down list to specify protein backbone atoms to be displayed in the model. 

• In the Styles column, select a style for displaying a group;  
• In the Schemes column, select a color mode for the elements of a group. Use 

the Custom option to choose other colors. 
 
For the Protein backbone group, the following options are available in the drop-and-
down lists of the Modes column: 

• Complete – Display all protein backbone atoms: Cα, N, C, and O. 
• Partial – Display only some protein backbone atoms: Cα, N, and C. 
• Trace – Display only Cα atoms in the protein backbone. 
• None – Hide protein backbones. 
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The Styles column has the following options for the Protein backbone, Protein 
sidechain, Nucleotide backbone, Nucleotide base, Solvent, and Heterogene groups: 

• Wire – A wire (skeleton) model. Atomic bonds are shown with lines.  
• Ball and Stick – A “ball and stick” model. Atoms are shown as spheres and 

atomic bonds, as sticks. The stick radius is set in the Stick size field and the 
sphere radius, in the Ball size field on the Atoms panel of the Sizes tab. 

• Stick – A stick model. Atomic bonds are shown as sticks. The stick radius is set 
in the Stick size field on the Atoms panel  of the Sizes tab. 

• CPK – A full atomic model (space-filling). The sphere radii are proportional to van 
der Waals atomic radii. The sphere scale is defined in the CPK scale field on the 
Atoms panel of the Sizes tab. 

 
The Styles list for the Protein structure group contains the following options: 
• Wire ribbon – Show a protein backbone as a thin ribbon. 
• Flat ribbon – Show a protein backbone as a flat ribbon. 
• Solid ribbon – Show a protein backbone as a solid ribbon. The ribbon width can 

be changed in the Ribbon width field of the Ribbons panel on the Sizes tab. 
• Wire schematic – Show a central line of the elements displayed in the Solid 

schematic view. 
• Solid schematic – Show schematically the secondary protein structure: 

α−helixes are displayed as wide sticks, β-sheets, as arrows, and transitions, 
turns, and unknown structures, as narrow sticks. The arrow width is set in the 
Strand width field and the radius of the sticks showing α-helixes, in the Helix 
radius field on the Schematic panel of the Sizes tab. 

• Wire trace – Display traces connecting the Cα atoms of the backbone. 
• Solid trace – Show sticks connecting the Cα-atoms of the backbone. The stick 

radius is set in the Trace radius field on the Trace panel of the Sizes tab. 
• Wire worm – Display the backbone as a thin line. 
• Solid worm – Display the backbone as a thin pipe. The pipe radius is set in the 

Worm radius field of the Trace panel on the Sizes tab. 
 
The Schemes list contains the following options: 

• By Element – the color of an atom is determined by the color of its chemical 
element (the colors of chemical elements are set in the Color dialog window, 
see Section 3.2.3). 

• By Residue – the color of an element of the model is determined by the residue 
it belongs to. In this case, the residue is any group of covalently bound atoms 
(aminoacids, nucleotides, and heterogroups). 

• By Chain – the color of an element of the model is determined by the chain it 
belongs to. 

• By molecule – the color of an element of the model is determined by the model 
it belongs to. 

• By hydrophobicity – the color of the surface dot is defined by the density of 
hydration energy (hydrophobic properties of the neighbor atoms in protein 
molecule) 

• By atom hydrophobicity – the color of the group’s element is defined by 
hydrophobic properties of the atom. 

• By residue hydrophobicity – the color of the group’s element is defined by 
hydrophobic properties of the residue, which it belongs to. 

• By charge – the color of the surface dot is defined by the electrostatic potential 
of protein molecule. 
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• By atom charge – the color of the group’s element is defined by the atom’s 
charge. 

• By pKa – the color of the group’s element is defined by the value of pKa 
constant. 

• By Secondary structure – the color of elements in a group depends on the 
secondary structure of a chain fragment. α-helixes are red, β-structures are blue, 
and turns and non-structured fragments are white. 

• By alignment – the color of elements in a group depends on the alignment 
pattern. Aligned fragments in sequences are red and non-aligned fragments are 
white. 

• Custom – the color of a group is defined by user. Click the  button to open the 
Color dialog window (see Section 3.9) where you can select a color.  

 
The Display options dialog window. The Geometry tab 

 
Figure 3.2.1.2.1. 

1. Groups’ names. 2. Groups displaying mode. 3. Lists for selection of displaying styles. 
4. Lists for selection of color schemes. 5. Buttons for selection of a color for “Custom” 
mode. 6. List for selection of models. 7. Button for closing the window and applying of 
selected options. 8. Button for applying of selected options without closing the window. 
9. Button for closing the window and rejecting of selected options. 

 
Comment. 

For Protein backbone and Protein sidechain groups, list Schemes contains all 
above-mentioned modes excepting By hydrophobicity and By charge ones. 

For Nucleotide backbone, Nucleotide base, Solvent and Heterogene groups, 
list Schemes contains By Element, By Residue, By Chain, By molecule and 
Custom modes only. 

For Protein structure group, list Schemes contains all modes excepting By 
Element, By hydrophobicity and By charge ones. 
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For Molecule surface group, list “Schemes” contains the following modes: By 
hydrophobicity, By charge and Custom. 

 
List Molecule is purposed for selecting the models that will be affected by 

changes, made on Geometry tab. 
Sizes tab 

On the Sizes tab (Fig. 3.2.1.2.2) you can change the geometrical parameters of 
models. 
• The Ribbons panel is used to customize the viewing parameters of the Wire 

ribbon, Flat ribbon, and Solid ribbon styles. 
o In the Ribbon width field, click the up and down arrows to specify the ribbon 

width. 
• The Schematic panel is used to change the viewing parameters of the Solid 

schematic style. 
o In the Strand width field, adjust the width of the arrows showing β-sheets.  
o In the Helix radius field, change the radius of the sticks denoting α-helixes. 

• The Trace panel is designed to change the viewing parameters of the Solid trace 
and Solid worm styles. 

o In the Trace radius field, change the radius of the trace in the Solid trace 
style. 

o In the Worm radius field, customize the radius of the thin pipe in the Solid 
worm style. 

 
The Display options dialog window. The Sizes tab 

 
Figure 3.2.1.2.2. 

1. “Ribbons” panel. 2. “Schematic” panel. 3. “Trace” panel. 4. “Atoms” panel. 5. 
“Surface” panel. 6. Button for closing the window and applying of selected options. 7. 
Button for applying of selected options without closing the window. 8. Button for closing 
the window and rejecting of selected options. 
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• The Atoms panel is used to change the following viewing parameters for atoms: 
o In the Ball size field, change the ball radius for the Ball and Stick style. 
o In the Stick size field, change the stick radius for the Ball and Stick style. 
o In the CPK Scale, customize the scale of spheres for the CPK style. 
o In the Star size field, adjust the size of stars showing standalone atoms 

(without bonds). 
• Panel Surface is purposed for changing the parameters of surfaces displaying: 

o Field Solvent radius is purposed for changing the radius of solvent. 
o Field Smooth factor is purposed for changing the value of smoothing factor. 

This parameter regulates the preciseness of molecule’s contour replication. 
The less parameter’s value, the better surface fits a molecule, however, at 
small values some defects in surface may appear. 

o Field Voxel count is purposed for regulating the quality of surface. The 
greater parameter’s value, the better quality, however, on increasing this 
value, the time consumption for calculations is also increased. 

3.2.2. Light options 
To open the Light options dialog window (Fig. 3.2.2.1), do one of the following: 
• Select View>Light options in the main menu. 
• Click the  toolbar button 

3D-Explorer allows the user to choose between six light sources that can be selected by 
checking the corresponding boxes:  

• Top-Left – the light source is placed on the left above the model. 
• Bottom-Left – the light source is placed on the left below the model. 
• Top-Right – the light source is placed on the right above the model. 
• Bottom-Right – the light source is placed on the right below the model. 
• Front – the light source is placed in front of the model. 
• Back –the light source is placed behind the model. 

Adjust the intensity of the light sources by moving the corresponding sliders. 
The Light options dialog window 

 
Figure 3.2.2.1. 

1. Sliders. 2. Upper left source. 3. Lower left source. 4. Upper right source. 5. Lower 
right source. 6. Front source. 7. Background source. 8. The OK button applies changes 
and closes the dialog window. 9. The Cancel button closes the dialog window and 
cancels changes.  
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3.2.3. Selecting colors of chemical elements 
You can change the colors of chemical elements in the Color dialog window 

(Fig. 3.2.3.1). To open this dialog window: 
• Select the View>Colors command in the main menu. 
• Click the  toolbar button. 
The Color dialog window contains colored buttons that are used to customize the 

colors of chemical elements. Each color corresponds to a certain element. 
Click a colored button with the name of a chemical element to open a dialog 

window for this specific element, for example, “NITROGEN” (Fig. 3.2.3.2): 
• The Color button shows the current color of the element. After you click this button, 

the Color dialog window will appear on your screen (see Section 3.9). In this dialog 
window, change the color of a chemical element. The Color button will change its 
color, too. Click OK to close the dialog window and apply changes. In the Color 
dialog window, the button with the name of the chemical element will be colored 
according to the changes you made. 

• The VDW Radius field contains the default value of the van der Waals radius of a 
chemical element. This value can be changed by the user. If you click OK in this 
dialog window and then click either the Close or Apply buttons in the Color dialog 
window, the model will be changed according to the new parameters. 

Dialog window control buttons: 
• Close – Apply changes and close the dialog window. 
• Apply – Apply changes and leave the dialog window open. 
• Restore – Reset the default values of the van der Waals radii of the elements and 

default colors. 
The Color dialog window 

Figure 3.2.3.1. 
1. Buttons for changing the colors of chemical elements. 2. The Close button. 3. The 
Apply button. 4. The Restore button. 
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The NITROGEN dialog window 

 
Figure 3.2.3.2. 

1. The button for adjusting the color of the chemical element. 2. The VDW Radius field 
for changing the default van der Waals radius of the element. 3. The OK button applies 
changes and closes the dialog window. 4. The Cancel button closes the dialog window 
and cancels changes. 

3.3. Moving the model 

3.3.1. Replacing the model 
To move the model, drag the molecule image over the view area with your 

mouse while pressing the Ctrl key on your keyboard. If  button is pressed, only 
selected elements of the scene can be replaced. 

 
3.3.2. Rotating the model 

You can rotate the model using your mouse. The rotation speed is adjusted in 
the Options dialog window (see Section 3.7). If  button is pressed, only selected 
elements of the scene can be rotated. 

The automatic rotation of the model is disabled by clicking 
View>Animation>Spin in the main menu. You can customize the rotation speed by 
setting the rotation delay (in milliseconds) in the Set delay dialog window. Select 
View>Animation>Set delay in the main menu to open this dialog window (Fig. 3.3.2.1). 
The automatic rotation of the model is available only in that case when there is no 
selected elements  on the scene. 

 
The Set delay dialog window 

 
Figure 3.3.2.1. 

1. The field for entering the delay value for shot changes. 2. The OK button applies 
changes and closes the dialog window. 3. The Cancel button closes the dialog window 
and cancels changes. 
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By default, the model turns around its geometrical center. You can change the 

geometrical center of the model. To set another geometrical center: 
1. Enable the center selection mode by clicking the  toolbar button. After this, the 

current geometrical center will be selected. 
2. Click the atom you want to set as a geometrical center. The new geometrical 

center will be selected in the view area. 
3. Disable the center selection mode by clicking the  toolbar button. 

3.3.3. Changing the distance to the model 
You can change the distance to the model using your mouse while pressing the 

Shift key on your keyboard. If the mouse pointer is moving downwards, the model is 
zoomed out; if the mouse pointer is moving upwards, the model is zoomed in. The 
scaling speed is adjusted in the Options dialog window (see Section 3.7). If  button 
is pressed, a distance to selected elements of the scene only can be changed. 

Comments. To load the initial image of the model, click the  toolbar button. 
To make the model fit the view area, click the  toolbar button. 

3.4. Selecting elements of the model 

You can select specific elements of the model by using your mouse. The 
selection mode is enabled by clicking the  toolbar button.  

When the  toolbar button is switched on, the following buttons become 
available: 

 – Normal selection mode – In this mode, each subsequent selection 
unselects the previously selected item. 

 – OR selection mode – In this mode, all subsequent selections are added to 
the previously selected items. 

 – XOR selection mode – In this mode, a previously selected item is 
unselected by subsequent selection. 

 
Click the  toolbar button to invert a selection.  
Click the  toolbar button to select all elements in the model. 
Click the  toolbar button to unselect all elements of the model. 
 
Comment. Elements of models can also be selected using “Tree explorer” and 
“Sequence viewer” dialog windows (see chapter 3.5), as well as context menu of display 
area (see chapter 2.4.1.1).. 

3.5. Lists of model elements 

3.5.1. Hierarchical tree 
The Tree explorer dialog window (Fig. 3.5.1.1) contains the hierarchical tree of 

the elements of a model that can be generated by: 
• Selecting the Window>Tree dialog option in the main menu. 
Or: 
• Clicking the  toolbar button. 

The Tree explorer dialog window contains the following elements: 
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• Control panel 
• List of model elements 
• Dialog window control buttons. 
 

The Tree explorer dialog window 

 
Figure 3.5.1.1. 

1. Control panel. 2. Tree of model elements. 3. Selections applied. 4. New selections. 5. 
The OK button. 6. The Apply button. 7. The Cancel button. 

 
Control panel buttons 

 – Enable the normal selection mode in which each subsequent selection unselects 
the previously selected item. To select an item, click it with your mouse. 

 – Enable the OR selection mode in which all subsequent selections are added to 
the previously selected items. To select an item, click it with your mouse. 

 – Enable the XOR selection mode in which a previously selected item is unselected 
by subsequent selection. To select an item, click it with your mouse. 

 – Expand the tree branch to the molecule level. 
 – Expand the tree branch to the chain level. 

 
 – Expand the tree branch to the residue level. 
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 – Expand the tree branch to the atom level. 
 – Select all elements in the tree. 
 – Unselect all elements in the tree. 

Tree of model elements 
The tree shows the hierarchical structure of model elements. You can select 

elements in the tree with your mouse. Change the selection modes by clicking the 
control panel buttons. 

The selected items are highlighted in blue. 
The elements with the applied selection are highlighted in pink. 

 
Dialog window control buttons 

• Click OK to apply selections and close the dialog window. 
• Click Apply to apply selections and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel the current selections. 

3.5.2. Sequence viewer dialog window 
You can open the Sequence viewer dialog window (Fig. 3.5.2.1) designed to 

view sequences of protein chains by: 
• Selecting the Window> Sequence viewer option in the main menu; 
• Clicking the  toolbar button. 

3.5.2.1. Structure of the Sequence viewer dialog window 
The Sequence viewer dialog window contains: 
• Control panel 
• Sequence view area 
• Dialog window control buttons 
• Status bar 

Control panel 
The control panel buttons have the following functions: 

 – Normal selection mode. In this mode, each subsequent selection unselects the 
previously selected item. To select an item, click it with your mouse or select a 
rectangular area with your mouse pointer. 

 – OR selection mode. In this mode, all subsequent selections are added to the 
previously selected items. To select an item, click it with your mouse or select a 
rectangular area with your mouse pointer. 

 – XOR selection mode. In this mode, a previously selected item is unselected by 
subsequent selection. To select an item, click it with your mouse or select a rectangular 
area with your mouse pointer. 

 – Rectangle area selection mode. In this mode, the program selects all residues 
within a rectangular area defined by the motion of your mouse. 

 – Lines selection mode. In this mode, the program selects all residues located in 
the rows you select by moving your mouse. 

 – Columns selection mode. In this mode, the program selects all residues located 
in the columns you select by moving your mouse. 

 – Options. Click this button to open the Options dialog window (see Section 
3.5.2.2) of the Sequence viewer dialog window. 
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The Sequence viewer dialog window 

 
Figure 3.5.2.1. 

1. Control panel. 2. Search result. 3. Sequence view area. 4. Mouse cursor position in 
the sequence view area (the residue is highlighted in blue). 5. Model name. 6. Chain 
identifiers. 7. Status bar. 8. The OK button. 9. The Apply button. 10. The Cancel 
button. 
 

 – Hide or show elements. Click this button to open the Visible and hidden 
elements dialog window in which you can enable/disable some models to be displayed 
in the sequence view area (see Section 3.5.2.3). 

 – Hide or show headers of elements. In this mode, model names are shown 
above chain sequences. 

 – Select all. Select all elements in the list. 
 – Deselect all. Deselect all elements in the list. 

In the upper right corner of the dialog window there is an input field used to 
search for specified fragments (templates) in chains. Enter a sequence into the field and 
press Enter. The fragment found will be highlighted in another color (Fig. 3.5.2.1). 

Sequence view area 
The sequence view area shows chain sequences in one-letter code (Fig. 

3.5.2.1). You can select residues within this view area. In the Options dialog window 
(see Section 3.5.2.2), you can change selection modes and color patterns for the 
sequence view area, including the background color. Note that selection modes can 
also be customized on the control panel. A residue marked with a red underscore 
belongs to an α-helix and that with a blue underscore, to a β−structure. 

On the left side of the area you can see chain identifiers selected for viewing. 
The names of chains containing recently selected residues are highlighted (the 
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highlighting color is set in the Options dialog window). The background color of chain 
names is customized in the Options dialog window. If you click the chain name, the 
entire sequence will be selected. 

The residues you are pointing to with your mouse is highlighted with a user-
defined color (Fig. 3.5.2.1). 

Dialog window control buttons: 
• Click OK to apply selections and close the dialog window. 
• Click Apply to apply selections and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel the current selections. 

Status bar 
The status bar shows: 

• Information about the residue you are pointing to with your mouse: residue name in 
three-letter code and its number in the PDB file (Fig. 3.5.2.1). 

• The name of the control panel button you are pointing to with your mouse. 

3.5.2.2. Options box of the Sequence viewer dialog window 

To open the Options dialog window, click the  control panel button in the 
Sequence viewer dialog window. The Options box has two tabs: the Common tab 
(Fig. 3.5.2.2.1) which allows you to adjust selection modes for the Sequence viewer 
dialog window and the Colors tab (Fig. 3.5.2.2.2) which serves to customize the colors 
of selected residues. 

Common tab 
• On the Symbol selection mode pane, you can set the following selection modes: 

o Normal mode – In this mode, each subsequent selection unselects the 
previously selected item. 

The Common tab 

 
Figure 3.5.2.2.1. 

1. The Symbol selection mode pane. 2. The Area selection style pane. 3. The OK 
button. 4. The Apply button. 5. The Cancel button. 
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o OR mode – In this mode, all subsequent selections are added to the 
previously selected items. 

o XOR mode – In this mode, a previously selected item is unselected by 
subsequent selection. 

• On the Area selection style pane, you can change the style of selecting residues in 
the selection view area: 

o Rectangle mode – In this mode, you select a rectangular area while 
moving your mouse. All residues within this area are automatically 
selected. 

o Rows selection mode – In this mode, you select all residues in a row 
while moving your mouse. 

o Columns selection mode – In this mode, you select all residues in a 
column while moving your mouse. 

Colors tab 
• On the Background color pane, you can select a background color for the 

sequence view area. The color of the button is the current background color. When 
you click this button, the Color dialog window appears on your screen. In this dialog 
window, you can select a background color (see Section 3.9 about the Color dialog 
window). 

 
The Colors tab 

 
Figure 3.5.2.2.2. 

1. The Background color pane. 2. The Unselected pane. 3. The Applied pane. 4. The 
Preview field. 5. The User selection field. 6. The User selection of applied pane. 7. 
The Symbol foreground pane. 8. The OK button. 9. The Apply button. 10. The Cancel 
button. 
 
• On the Unselected pane, you can select a color for unselected residues. The color 

of the button is the current color of unselected elements. When you click this button, 
the Color dialog window appears on your screen. In this dialog window, you can 
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customize the color of unselected residues (see Section 3.9 about the Color dialog 
window). 

• On the Applied pane, you can select a color for applied selections. The button 
displays the current color. When you click this button, the Color dialog window 
appears on your screen. In this dialog window, you can select a color for applied 
selections (see Section 3.9 about the Color dialog window). 

• On the User selection pane, you can select a color for new selections. The button 
displays the current color of new selections. When you click this button, the Color 
dialog window appears on your screen. In this dialog window, you can set a color for 
new selections (see Section 3.9 about the Color dialog window). 

• On the User selection of applied pane, you can select a color for sections of 
overlying new and applied selections. The button displays the current color of these 
sections. When you click this button, the Color dialog window appears on your 
screen. In this dialog window, you can select a color of these sections (see 
Section 3.9 about the Color dialog window). 

• On the Symbol foreground pane, you can customize a color of residues. The 
button displays the current color of symbols. When you click this button, the Color 
dialog window appears on your screen. In this dialog window, you can customize the 
color of symbols (see Section 3.9 about the Color dialog window). 

• In the Preview field, you can preview the customized colors. 
 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Apply to apply changes and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel changes. 

3.5.2.3. Visible and hidden elements dialog window 
To open the Visible and hidden elements dialog window (Fig. 3.5.2.3.1), click 

the  control panel button in the Sequence viewer dialog window. In the Visible and 
hidden elements dialog window, you can change the content and order of models and 
alignments as they are displayed in the sequence view area of the Sequence viewer 
dialog window. 

To show specific models or alignments, follow these steps: 
1. Select the identifiers of models and alignments in the Hidden list by clicking your 

mouse (if you want to unselect a selected identifier, click it with your mouse). 

2. Click the  button. After this, the selected identifiers will be removed from the 
Hidden list and added to the end of the Visible list in the same order as they 
were arranged in the Hidden list. 

To hide some models, follow these steps: 
1. Select the corresponding model identifiers and alignments in the Visible list by 

clicking your mouse (if you want to unselect a selected identifier, click it with your 
mouse). 

2. Click the  button. After this, the selected identifiers will be removed from the 
Visible list and added to the end of the Hidden list in the same order as they 
were in the Visible list. 
 

To change the order of models in the lists, click the  or  buttons to shift a 
model one step below or above.  

 
Dialog window control buttons: 
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• Click OK to apply changes and close the dialog window. 
• Click Apply to apply changes and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel changes. 

 
The Visible and hidden dialog window 

 
Figure 3.5.2.3.1. 

1. The button for moving the selected models upwards. 2. The button for moving the 
selected models downwards. 3. The button for hiding selected models. 4. The button for 
showing selected models. 5. The Visible list. 6. The Hidden list. 7. The OK button. 8. 
The Apply button. 9. The Cancel button. 

3.6. Selecting scene elements to be displayed 

You can select specific atoms, chains, residues, and chemical elements to be 
displayed in a model on the Model options dialog window (Fig. 3.6.1). To open this 
dialog window, do the following: 

• Select View>Model options in the main menu. 
• Click the  control panel button. 

The information panel displays the following data about all loaded models and for 
the model selected in the drop-and-down list: 

1. The total number of chains, residues, and atoms in models and the number of 
displayed atoms. 

2. The number of selected atoms. 
You can select a model in the list of model identifiers and change the parameters 

of the selected model on the Atoms, Residues, Chains, and Elements tabs. 
On the Atoms tab, you can select atoms to be displayed in the selected model. 

The list contains the names of atoms in a model. To show or hide atoms, check ( ) or 
uncheck ( ) the corresponding boxes. Click the control panel buttons to display the 
following groups of atoms: 

•  – all atoms in the list. 

•  – protein backbone atoms: Cα, N, C, and O. 
•  – some of the protein backbone atoms: Cα, N, and C. 
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•  – only Cα- atoms in the protein backbone. 
•  – all hydrogen atoms are hidden. 

 
The Model options dialog window. The Atoms tab 

 
Figure 3.6.1. 

1. Control panel. 2. List of atoms. 3. Information panel. 4. List of identifiers of the models 
loaded. 5. The OK button. 6. The Apply button. 7. The Cancel button. 
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The Residues tab (Fig. 3.6.2) serves to select the residues to be displayed in a 

model. The list contains chain identifiers with residue ranges for each chain. To change 
the residue range, select the chain and insert the required values in the from and to 
fields. If you click the MIN button, the position number of the first residue in the chain 
appears in the from field. If you click the MAX button, the position number of the last 
residue in the chain appears in the to field. 

 
The Model options dialog window. The Residues tab 

 
Figure 3.6.2. 

1. Fields for changing the range of displayed residues. 2. List of chain identifiers with 
residue ranges. 3. Information panel. 4. Identifiers of the models loaded. 5. The OK 
button. 6. The Apply button. 7. The Cancel button. 
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The Model options dialog window. The Chains tab 

 
Figure 3.6.3. 

1. List of chains. 2. Information panel. 3. List of identifiers of models loaded. 4. The OK 
button. 5. The Apply button. 6. The Cancel button. 

 
The Elements tab (Fig. 3.6.4) serves to select the chemical elements to be 

displayed in a model. The list contains the names of chemical elements. To show or 
hide chemical elements, check ( ) or uncheck ( ) the corresponding boxes. 
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The Model options dialog window. The Elements tab 

 
Figure 3.6.4. 

1. List of chemical elements. 2. Information panel. 3. Identifiers of loaded models. 
4. The OK button. 5. The Apply button. 6. The Cancel button. 

 
The Models tab (Fig. 3.6.5) serves to select the models to be displayed. The list 

contains model identifiers. To show or hide models, check ( ) or uncheck ( ) the 
corresponding boxes. 
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The Model options dialog window. The Models tab 

 
Figure 3.6.5. 

1. Model identifiers list. 2. Information panel. 3. Identifiers of loaded models. 4. The OK 
button. 5. The Apply button. 6. The Cancel button. 
 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Apply to apply changes and leave the dialog window open.  
• Click Cancel to close the dialog window and cancel changes. 
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3.7. Options dialog window 

On the Options dialog window (Fig. 3.7.1), you can set the general parameters of 
the model and mouse parameters. To open the Options dialog window, do the 
following: 

• Select the View>Options option in the main menu. 
• Click the  control panel button. 
 

The Options dialog window 

 
Figure 3.7.1. 

1. The field for entering the distance to the model. 2. Detail level. 3. Rotation speed. 4. 
Scaling speed. 5. The button for selecting the background color for the view area. 
6. The OK button. 7. The Cancel button. 
In the Options dialog window, you can change: 

• The distance to the model in the Model scale field. 
• The quality of model images in the Detail level field. For example, the value 2 

corresponds to the Very low detail level (also set by clicking the View->Detail 
level->Very low option in the main menu), 5 to the Low level, 15 to the Normal 
level, 25 to the High level, and 40 to the Very high level. 

• The sensitivity of rotation to mouse motion adjusted in the Rotation speed field.  
• The sensitivity of scaling to mouse motion set in the Scaling speed field. 
• The background color of the view area. Click Background button to open the 

Color dialog window and select a background color. See Section 3.9 about the 
Color dialog window. 

Dialog window control buttons: 
• Click OK to apply changes and close the dialog window. 
• Click Cancel to cancel changes and close the dialog window. 

3.8. Matrix diagram dialog window 

In the Matrix diagram dialog window (Fig. 3.8.1), you can set the program to 
display structural features of models as matrix diagrams. To open the Matrix diagram 
dialog window, do the following:  
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• Select the Window>Matrix viewer option in the main menu.  
• Click the  control panel button.  

 The color of each cell in the diagram depends in the value of the corresponding 
matrix element. You can change the type and view mode for your matrices. 

 
The Matrix diagram dialog window 

 
Figure 3.8.1. 

1. Drop-and-down list for selecting the mode for the upper matrix. 2. The drop-and-down 
list for selecting the mode for the lower matrix. 3. Types of elements. 4. Model 
identifiers. 5. Secondary structure. 6. Upper matrix. 7. Lower matrix. 8. Mouse pointer 
position. 9. The Close button. 10. The Clone button. 11. Status bar. 

 
Use the Type drop-and-down list to select the types of elements to be displayed in a 

matrix diagram. The following variants are available: 
• Residue – The diagram shows relationships between standard groups of atoms, 

including aminoacids, nucleotides, and heterogroups. 
• Atom – The diagram shows relationships between atoms. 
• AA-Residue – The diagram shows relationships between aminoacid residues. 
The upper matrix mode can be selected in the Mode 2 drop-and-down list and the 

lower matrix mode can be selected in the Mode 1 drop-and-down list. The following 
matrix modes are available: 

• Distance – Show distances between matrix elements. 
• Identity – Show similarities between the types of elements. 
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• SS bond – Show disulphide bonds. 
• Hydrogen bonds – Show hydrogen bonds. 
 
In the Model drop-and-down list, select the identifier of the model to be displayed as 

a matrix. The list contains identifiers of all loaded models. 
The secondary molecular structure is shown on the left and below the matrix. α-helix 

fragments are shown in red, β-structures are blue, and turns and non-structured 
elements are white. 

The status bar displays the following data about the pair of elements marked with 
the mouse pointer in the matrix diagram: the distance between them in the Distance 
mode, their resemblance in the Identity mode, the presence or absence of hydrogen 
bonds in the Hydrogen bonds mode, and the presence or absence of disulphide bonds 
in the SS bond mode.  

Click the Clone button to make a copy of this dialog window. 
Click the Close button to close this dialog window. 
 

 37



3.9. Color dialog window 

In the Color dialog window (Fig. 3.9.1), you can select colors of your models. 
To change colors, do one of the following: 

• Basic colors. Click a color box to change the basic color. You will see the new 
color in the color preview box. To confirm your selection, click OK. 

• Custom colors. Click the color selector and pick the required color. You will see 
the new color in the color preview box. To confirm your selection, click OK. 

• New color. To add a new color, you can move a slider, color selector, or the HSB 
or RGB color fields. The new color will appear in the color preview box. To 
confirm your selection, click OK. 

Comment. To change a custom color, click the custom color box and then change 
the color by moving the slider selector or inserting the required values in the HSB or 
RGB color fields. After this, click the Add to Custom Colors button. The new custom 
color will appear in the custom color boxes. 

 
The Color dialog window 

 
Figure 3.9.1. 

1. Basic colors. 2. Custom colors. 3. Slider. 4. Color selector. 5. Current color preview 
box. 6. The HSB color model. 7. The RGB color model. 8. The OK button. 9. The 
Cancel button. 10. The Add to Custom Colors button.  

 
Dialog window control buttons 

Click the Apply color button to apply changes and leave the dialog window open or 
click OK to apply changes and close the dialog window. Click the Cancel button to 
cancel changes. 

4. References 
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5. Copyrights 
3D-Explorer Copyrights, Softberry 2003-2005 
 
All, data, programs, scripts, binary and source codes in this paskage are copyright 

Softberry, Inc., and cannot be copied, redistributed, sold, decompiled, reverse 
engineered or otherwise changed without permission. Data and codes  downloadable 
from Softberry site cannot be sold, licensed or redistributed in any form without 
permission. 
 

Softberry makes no warranties whatsoever regarding programs and data, and 
shall not be liable for any damages resulting from use of its programs and data. 
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